ANT Users: How to Fix Java Error ‘Java Version Mismatch, please use java version less than 1.8.0.201. Actual version: x.x.x_xxx’

If you receive this error message ‘Java Version Mismatch, please use java version less than 1.8.0.201. Actual version: x.x.x_xxx’, it is because you are using a version of Java that is different than what your version of Provar supports via ANT.

There are some instances in which you need to use an older version of Java in order for Provar to function correctly.

How Can I Fix This Issue?

  • If you upgrade to Provar v1.9.9.03, you need to uninstall your current version of Java and install version 1.8.0_172 or lower
  • If you upgrade to Provar v1.9.9.04, you need to uninstall your current version of Java and install a version of Java that falls within this range (1.8.0_172 through 1.8.0_212)

Overview of Provar & Java Compatibility Requirements

 

Provar Version Use Java Version
ANT 1.9.8.07 1.8.0_181 or lower
ANT 1.9.9.03 1.8.0_172 or lower
ANT 1.9.9.04 1.8.0_172 through 1.8.0_212